public inbox for passt-dev@passt.top
 help / color / mirror / code / Atom feed
From: David Gibson <david@gibson.dropbear.id.au>
To: Laurent Vivier <lvivier@redhat.com>
Cc: passt-dev@passt.top
Subject: Re: [PATCH 05/18] packet: Add packet_base()
Date: Thu, 3 Apr 2025 15:59:48 +1100	[thread overview]
Message-ID: <Z-4VxMWpzbT7vjsF@zatzit> (raw)
In-Reply-To: <20250402172343.858187-6-lvivier@redhat.com>

[-- Attachment #1: Type: text/plain, Size: 3524 bytes --]

On Wed, Apr 02, 2025 at 07:23:30PM +0200, Laurent Vivier wrote:
> Signed-off-by: Laurent Vivier <lvivier@redhat.com>

Needs commit message.

> ---
>  packet.c | 37 +++++++++++++++++++++++++++++++++++++
>  packet.h |  7 +++++++
>  2 files changed, 44 insertions(+)
> 
> diff --git a/packet.c b/packet.c
> index 8b11e0850ff6..25ede38b94cb 100644
> --- a/packet.c
> +++ b/packet.c
> @@ -156,6 +156,43 @@ void *packet_get_do(const struct pool *p, size_t idx, size_t offset,
>  	return ptr;
>  }
>  
> +/**
> + * packet_base_do() - Get data range from packet descriptor from given pool
> + * @p:		Packet pool
> + * @idx:	Index of packet descriptor in pool
> + * @func:	For tracing: name of calling function, NULL means no trace()
> + * @line:	For tracing: caller line of function call
> + *
> + * Return: pointer to start of data range, NULL on invalid range or descriptor

All these comments need to be updated, they seem to be based on (an
old version of?) packet_get_do and are no longer accurate.

"packet_base()" also doesn't really convey the meaning to me.  Not
sure what a better name is, though.


> + */
> +/* cppcheck-suppress unusedFunction */
> +bool packet_base_do(const struct pool *p, size_t idx,
> +		   struct iov_tail *data,
> +		   const char *func, int line)
> +{
> +	size_t i;
> +
> +	if (idx >= p->size || idx >= p->count) {
> +		if (func) {
> +			trace("packet %zu from pool size: %zu, count: %zu, "
> +			      "%s:%i", idx, p->size, p->count, func, line);
> +		}
> +		return NULL;
> +	}
> +
> +	data->cnt = 1;
> +	data->off = 0;
> +	data->iov = &p->pkt[idx];
> +
> +	for (i = 0; i < data->cnt; i++) {
> +		if (packet_check_range(p, data->iov[i].iov_base,
> +				       data->iov[i].iov_len, func, line))
> +			return false;

This looks to be based logically on versions of packet_get_do() before
I did my rework in 38bcce997 and surrounding commits.  If we get a
packet_check_range() failure here it means the packet pool is already
corrupt and we should just ASSERT.

The conditions on func being non-NULL should also be gone.


> +	}
> +
> +	return true;
> +}
> +
>  /**
>   * pool_flush() - Flush a packet pool
>   * @p:		Pointer to packet pool
> diff --git a/packet.h b/packet.h
> index f386295da203..35058e747a43 100644
> --- a/packet.h
> +++ b/packet.h
> @@ -35,6 +35,9 @@ void packet_add_do(struct pool *p, struct iov_tail *data,
>  void *packet_get_do(const struct pool *p, const size_t idx,
>  		    size_t offset, size_t len, size_t *left,
>  		    const char *func, int line);
> +bool packet_base_do(const struct pool *p, const size_t idx,
> +		    struct iov_tail *data,
> +		    const char *func, int line);
>  void pool_flush(struct pool *p);
>  
>  #define packet_add(p, data)					\
> @@ -43,9 +46,13 @@ void pool_flush(struct pool *p);
>  #define packet_get(p, idx, offset, len, left)				\
>  	packet_get_do(p, idx, offset, len, left, __func__, __LINE__)
>  
> +
>  #define packet_get_try(p, idx, offset, len, left)			\
>  	packet_get_do(p, idx, offset, len, left, NULL, 0)
>  
> +#define packet_base(p, idx, data)					\
> +	packet_base_do(p, idx, data, __func__, __LINE__)
> +
>  #define PACKET_POOL_DECL(_name, _size, _buf)				\
>  struct _name ## _t {							\
>  	char *buf;							\

-- 
David Gibson (he or they)	| I'll have my music baroque, and my code
david AT gibson.dropbear.id.au	| minimalist, thank you, not the other way
				| around.
http://www.ozlabs.org/~dgibson

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

  reply	other threads:[~2025-04-03  5:38 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-02 17:23 [PATCH 00/18] Introduce discontiguous frames management Laurent Vivier
2025-04-02 17:23 ` [PATCH 01/18] arp: Don't mix incoming and outgoing buffers Laurent Vivier
2025-04-03  1:57   ` David Gibson
2025-04-02 17:23 ` [PATCH 02/18] iov: Update IOV_REMOVE_HEADER() and IOV_PEEK_HEADER() Laurent Vivier
2025-04-03  2:36   ` David Gibson
2025-04-02 17:23 ` [PATCH 03/18] tap: Use iov_tail with tap_add_packet() Laurent Vivier
2025-04-03  4:50   ` David Gibson
2025-04-02 17:23 ` [PATCH 04/18] packet: Use iov_tail with packet_add() Laurent Vivier
2025-04-03  4:54   ` David Gibson
2025-04-02 17:23 ` [PATCH 05/18] packet: Add packet_base() Laurent Vivier
2025-04-03  4:59   ` David Gibson [this message]
2025-04-02 17:23 ` [PATCH 06/18] arp: Convert to iov_tail Laurent Vivier
2025-04-03  5:00   ` David Gibson
2025-04-02 17:23 ` [PATCH 07/18] ndp: " Laurent Vivier
2025-04-03  5:01   ` David Gibson
2025-04-02 17:23 ` [PATCH 08/18] icmp: " Laurent Vivier
2025-04-03  5:04   ` David Gibson
2025-04-02 17:23 ` [PATCH 09/18] udp: " Laurent Vivier
2025-04-03  5:11   ` David Gibson
2025-04-02 17:23 ` [PATCH 10/18] tcp: Convert tcp_tap_handler() to use iov_tail Laurent Vivier
2025-04-03  5:14   ` David Gibson
2025-04-02 17:23 ` [PATCH 11/18] tcp: Convert tcp_data_from_tap() " Laurent Vivier
2025-04-03  5:20   ` David Gibson
2025-04-02 17:23 ` [PATCH 12/18] dhcpv6: Convert to iov_tail Laurent Vivier
2025-04-03  5:21   ` David Gibson
2025-04-02 17:23 ` [PATCH 13/18] dhcpv6: move offset initialization out of dhcpv6_opt() Laurent Vivier
2025-04-03  5:25   ` David Gibson
2025-04-02 17:23 ` [PATCH 14/18] dhcpv6: Use iov_tail in dhcpv6_opt() Laurent Vivier
2025-04-03  5:37   ` David Gibson
2025-04-02 17:23 ` [PATCH 15/18] dhcp: Convert to iov_tail Laurent Vivier
2025-04-03  5:47   ` David Gibson
2025-04-02 17:23 ` [PATCH 16/18] tap: " Laurent Vivier
2025-04-03 23:19   ` David Gibson
2025-04-02 17:23 ` [PATCH 17/18] ip: Use iov_tail in ipv6_l4hdr() Laurent Vivier
2025-04-03 23:21   ` David Gibson
2025-04-02 17:23 ` [PATCH 18/18] tap: Convert to iov_tail Laurent Vivier
2025-04-03 23:26   ` David Gibson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Z-4VxMWpzbT7vjsF@zatzit \
    --to=david@gibson.dropbear.id.au \
    --cc=lvivier@redhat.com \
    --cc=passt-dev@passt.top \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://passt.top/passt

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for IMAP folder(s).