On Tue, Feb 27, 2024 at 03:25:51PM +0100, Stefano Brivio wrote: > On Thu, 22 Feb 2024 16:55:59 +1100 > David Gibson wrote: > > > We have several places where we want to write(2) a buffer or buffers and we > > do (or should) handle sort write()s by retrying until everything is > > After making sure that "handle sorting" doesn't exist (yet): is one > between "handle" and "sort" redundant, or is there another meaning to > this? Oops. s/sort/short/ is what makes this make sense. > > > successfully written. Add a helper for this in util.c. > > > > This version has some differences from the typical write_all() function. > > First, take an IO vector rather than a single buffer, because that will be > > useful for some of our cases. Second, allow it to take an parameter to > > skip the first n bytes of the given buffers. This will be usefl for some > > of the cases we want, and also falls out quite naturally from the > > implementation. > > > > Signed-off-by: David Gibson > > --- > > util.c | 32 ++++++++++++++++++++++++++++++++ > > util.h | 1 + > > 2 files changed, 33 insertions(+) > > > > diff --git a/util.c b/util.c > > index fb6a0430..a475f2b5 100644 > > --- a/util.c > > +++ b/util.c > > @@ -19,6 +19,7 @@ > > #include > > #include > > #include > > +#include > > #include > > #include > > #include > > @@ -597,3 +598,34 @@ size_t iov_offset(const struct iovec *iov, size_t n, size_t *offset) > > > > return i; > > } > > + > > +/* write_remainder() - write the tail of an IO vector to an fd > > + * @fd: File descriptor > > + * @iov: IO vector > > + * @iovcnt: Number of entries in @iov > > + * @skip: Number of bytes of the vector to skip writing > > + * > > + * Return: 0 on success, -1 on error (with errno set) > > + * > > + * #syscalls write writev > > + */ > > +int write_remainder(int fd, const struct iovec *iov, int iovcnt, size_t skip) > > +{ > > + int i; > > + > > + while ((i = iov_offset(iov, iovcnt, &skip)) < iovcnt) { > > With my proposal for 1/6 this becomes: > > while ((i = iov_entry_index(iov, iovcnt, skip, &offset)) < iovcnt) { Hrm, the easiest conversion is to use (..., skip, &skip). Using a new variable means we'd need to feed that back into skip somehow on the next loop. > > if (offset) > ... > > which I don't really find brilliant, but at least we don't do if (skip) > where 'skip' used to be something completely different. So.. the version I have now you might not like based on this comment, because it still has 'skip' essentially become a local variable with a different meaning from the one it has at entry. > > + ssize_t rc; > > + > > + if (skip) > > Curly brackets here for consistency (undecided about readability to be > honest). Uh.. consistency with what? We don't typically brace single line clauses in passt. > > > + rc = write(fd, (char *)iov[i].iov_base + skip, > > + iov[i].iov_len - skip); > > + else > > + rc = writev(fd, &iov[i], iovcnt - i); > > + > > + if (rc < 0) > > + return -1; > > + skip += rc; > > + } > > + > > + return 0; > > +} > > diff --git a/util.h b/util.h > > index 62fad6fe..ee380f55 100644 > > --- a/util.h > > +++ b/util.h > > @@ -230,6 +230,7 @@ int __daemon(int pidfile_fd, int devnull_fd); > > int fls(unsigned long x); > > int write_file(const char *path, const char *buf); > > size_t iov_offset(const struct iovec *iov, size_t n, size_t *offset); > > +int write_remainder(int fd, const struct iovec *iov, int iovcnt, size_t skip); > > > > /** > > * mod_sub() - Modular arithmetic subtraction > -- David Gibson | I'll have my music baroque, and my code david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_ | _way_ _around_! http://www.ozlabs.org/~dgibson