On Fri, Oct 25, 2024 at 01:04:37AM +0200, Stefano Brivio wrote: > /home/sbrivio/passt/udp.c:171:1: error: inital values in enum 'udp_iov_idx' are not consistent, consider explicit initialization of all, none or only the first enumerator [cert-int09-c,readability-enum-initial-value,-warnings-as-errors] > 171 | enum udp_iov_idx { > | ^ > 172 | UDP_IOV_TAP = 0, > 173 | UDP_IOV_ETH = 1, > 174 | UDP_IOV_IP = 2, > 175 | UDP_IOV_PAYLOAD = 3, > 176 | UDP_NUM_IOVS > | > | = 4 > > Make sure we initialise all the values, in this case. Oof. Although it's a bit weird, I quite like the existing style, because it gives the correct value for NUM_WHATEVER without requiring editing if a new explicit value is inserted above it. I'd be inclined to use a suppression rather than changing the code. > > Signed-off-by: Stefano Brivio > --- > udp.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/udp.c b/udp.c > index 100610f..89f2959 100644 > --- a/udp.c > +++ b/udp.c > @@ -173,7 +173,7 @@ enum udp_iov_idx { > UDP_IOV_ETH = 1, > UDP_IOV_IP = 2, > UDP_IOV_PAYLOAD = 3, > - UDP_NUM_IOVS > + UDP_NUM_IOVS = UDP_IOV_PAYLOAD + 1, > }; > > /* IOVs and msghdr arrays for receiving datagrams from sockets */ -- David Gibson (he or they) | I'll have my music baroque, and my code david AT gibson.dropbear.id.au | minimalist, thank you, not the other way | around. http://www.ozlabs.org/~dgibson