public inbox for passt-dev@passt.top
 help / color / mirror / code / Atom feed
* [PATCH v2 0/6] udp: Small cleanups
@ 2024-03-06  5:34 David Gibson
  2024-03-06  5:34 ` [PATCH v2 1/6] udp: Refactor udp_sock[46]_iov_init() David Gibson
                   ` (6 more replies)
  0 siblings, 7 replies; 8+ messages in thread
From: David Gibson @ 2024-03-06  5:34 UTC (permalink / raw)
  To: Stefano Brivio, passt-dev; +Cc: David Gibson

Following on from the recent set of small fixes for UDP, here are a
number of small cleanups to the UDP code, which will simplify later
more complex fixes and improvements.

Laurent, I expect this will have some conflicts with part 2 of your
vhost-user work, though I hope they won't be too bad.

This is now based on part 1 of Laurent's vhost-user series
(specifically the version I posted with the static checker regressions
fixed).

Changes since v1:
 * Rebased on Laurent's vhost-user part 1 patches
 * Some improved commit messages

David Gibson (6):
  udp: Refactor udp_sock[46]_iov_init()
  udp: Consistent port variable names in udp_update_hdr[46]
  udp: Pass data length explicitly to to udp_update_hdr[46]
  udp: Re-order udp_update_hdr[46] for clarity and brevity
  udp: Avoid unnecessary pointer in udp_update_hdr4()
  udp: Use existing helper for UDP checksum on inbound IPv6 packets

 udp.c | 211 +++++++++++++++++++++++++++-------------------------------
 1 file changed, 99 insertions(+), 112 deletions(-)

-- 
2.44.0


^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2024-03-13 14:22 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-03-06  5:34 [PATCH v2 0/6] udp: Small cleanups David Gibson
2024-03-06  5:34 ` [PATCH v2 1/6] udp: Refactor udp_sock[46]_iov_init() David Gibson
2024-03-06  5:34 ` [PATCH v2 2/6] udp: Consistent port variable names in udp_update_hdr[46] David Gibson
2024-03-06  5:34 ` [PATCH v2 3/6] udp: Pass data length explicitly to to udp_update_hdr[46] David Gibson
2024-03-06  5:34 ` [PATCH v2 4/6] udp: Re-order udp_update_hdr[46] for clarity and brevity David Gibson
2024-03-06  5:34 ` [PATCH v2 5/6] udp: Avoid unnecessary pointer in udp_update_hdr4() David Gibson
2024-03-06  5:34 ` [PATCH v2 6/6] udp: Use existing helper for UDP checksum on inbound IPv6 packets David Gibson
2024-03-13 14:21 ` [PATCH v2 0/6] udp: Small cleanups Stefano Brivio

Code repositories for project(s) associated with this public inbox

	https://passt.top/passt

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for IMAP folder(s).