public inbox for passt-dev@passt.top
 help / color / mirror / code / Atom feed
From: David Gibson <david@gibson.dropbear.id.au>
To: Stefano Brivio <sbrivio@redhat.com>
Cc: passt-dev@passt.top, Laurent Vivier <lvivier@redhat.com>
Subject: Re: [PATCH 3/6] util: Add write_remainder() helper
Date: Wed, 28 Feb 2024 11:44:28 +1100	[thread overview]
Message-ID: <Zd6B7IpsZJbEu5GA@zatzit> (raw)
In-Reply-To: <20240227152551.72d8744f@elisabeth>

[-- Attachment #1: Type: text/plain, Size: 4015 bytes --]

On Tue, Feb 27, 2024 at 03:25:51PM +0100, Stefano Brivio wrote:
> On Thu, 22 Feb 2024 16:55:59 +1100
> David Gibson <david@gibson.dropbear.id.au> wrote:
> 
> > We have several places where we want to write(2) a buffer or buffers and we
> > do (or should) handle sort write()s by retrying until everything is
> 
> After making sure that "handle sorting" doesn't exist (yet): is one
> between "handle" and "sort" redundant, or is there another meaning to
> this?

Oops.  s/sort/short/ is what makes this make sense.

> 
> > successfully written.  Add a helper for this in util.c.
> > 
> > This version has some differences from the typical write_all() function.
> > First, take an IO vector rather than a single buffer, because that will be
> > useful for some of our cases.  Second, allow it to take an parameter to
> > skip the first n bytes of the given buffers.  This will be usefl for some
> > of the cases we want, and also falls out quite naturally from the
> > implementation.
> > 
> > Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
> > ---
> >  util.c | 32 ++++++++++++++++++++++++++++++++
> >  util.h |  1 +
> >  2 files changed, 33 insertions(+)
> > 
> > diff --git a/util.c b/util.c
> > index fb6a0430..a475f2b5 100644
> > --- a/util.c
> > +++ b/util.c
> > @@ -19,6 +19,7 @@
> >  #include <arpa/inet.h>
> >  #include <net/ethernet.h>
> >  #include <sys/epoll.h>
> > +#include <sys/uio.h>
> >  #include <fcntl.h>
> >  #include <string.h>
> >  #include <time.h>
> > @@ -597,3 +598,34 @@ size_t iov_offset(const struct iovec *iov, size_t n, size_t *offset)
> >  
> >  	return i;
> >  }
> > +
> > +/* write_remainder() - write the tail of an IO vector to an fd
> > + * @fd:		File descriptor
> > + * @iov:	IO vector
> > + * @iovcnt:	Number of entries in @iov
> > + * @skip:	Number of bytes of the vector to skip writing
> > + *
> > + * Return: 0 on success, -1 on error (with errno set)
> > + *
> > + * #syscalls write writev
> > + */
> > +int write_remainder(int fd, const struct iovec *iov, int iovcnt, size_t skip)
> > +{
> > +	int i;
> > +
> > +	while ((i = iov_offset(iov, iovcnt, &skip)) < iovcnt) {
> 
> With my proposal for 1/6 this becomes:
> 
> 	while ((i = iov_entry_index(iov, iovcnt, skip, &offset)) < iovcnt) {

Hrm, the easiest conversion is to use (..., skip, &skip).  Using a new
variable means we'd need to feed that back into skip somehow on the
next loop.

> 
> 		if (offset)
> 			...
> 
> which I don't really find brilliant, but at least we don't do if (skip)
> where 'skip' used to be something completely different.

So.. the version I have now you might not like based on this comment,
because it still has 'skip' essentially become a local variable with a
different meaning from the one it has at entry.

> > +		ssize_t rc;
> > +
> > +		if (skip)
> 
> Curly brackets here for consistency (undecided about readability to be
> honest).

Uh.. consistency with what?  We don't typically brace single line
clauses in passt.

> 
> > +			rc = write(fd, (char *)iov[i].iov_base + skip,
> > +				   iov[i].iov_len - skip);
> > +		else
> > +			rc = writev(fd, &iov[i], iovcnt - i);
> > +
> > +		if (rc < 0)
> > +			return -1;
> > +		skip += rc;
> > +	}
> > +
> > +	return 0;
> > +}
> > diff --git a/util.h b/util.h
> > index 62fad6fe..ee380f55 100644
> > --- a/util.h
> > +++ b/util.h
> > @@ -230,6 +230,7 @@ int __daemon(int pidfile_fd, int devnull_fd);
> >  int fls(unsigned long x);
> >  int write_file(const char *path, const char *buf);
> >  size_t iov_offset(const struct iovec *iov, size_t n, size_t *offset);
> > +int write_remainder(int fd, const struct iovec *iov, int iovcnt, size_t skip);
> >  
> >  /**
> >   * mod_sub() - Modular arithmetic subtraction
> 

-- 
David Gibson			| I'll have my music baroque, and my code
david AT gibson.dropbear.id.au	| minimalist, thank you.  NOT _the_ _other_
				| _way_ _around_!
http://www.ozlabs.org/~dgibson

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

  reply	other threads:[~2024-02-28  1:02 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-02-22  5:55 [PATCH 0/6] Allow more use of iovecs in pcap and tap interfaces David Gibson
2024-02-22  5:55 ` [PATCH 1/6] util: Add helper to find offset into io vector David Gibson
2024-02-27 14:23   ` Stefano Brivio
2024-02-27 23:27     ` David Gibson
2024-02-22  5:55 ` [PATCH 2/6] pcap: Update pcap_frame() to take an iovec and offset David Gibson
2024-02-27 14:23   ` Stefano Brivio
2024-02-22  5:55 ` [PATCH 3/6] util: Add write_remainder() helper David Gibson
2024-02-27 14:25   ` Stefano Brivio
2024-02-28  0:44     ` David Gibson [this message]
2024-02-28  6:24       ` Stefano Brivio
2024-02-28  9:04         ` David Gibson
2024-02-28  9:22           ` Stefano Brivio
2024-02-22  5:56 ` [PATCH 4/6] pcap: Handle short writes in pcap_frame() David Gibson
2024-02-22  5:56 ` [PATCH 5/6] pcap: Allow pcap_frame() and pcap_multiple() to take multi-buffer frames David Gibson
2024-02-27 14:26   ` Stefano Brivio
2024-02-22  5:56 ` [PATCH 6/6] tap: Use write_remainder() in tap_send_frames_passt() David Gibson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Zd6B7IpsZJbEu5GA@zatzit \
    --to=david@gibson.dropbear.id.au \
    --cc=lvivier@redhat.com \
    --cc=passt-dev@passt.top \
    --cc=sbrivio@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://passt.top/passt

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for IMAP folder(s).